网址导航 在线音乐 免费电影 美女图片 笑话漫画 免费代理 电视影视 小说阅读

八零后论坛

 找回密码
 注册
搜索
查看: 666|回复: 0

LAMP一键安装包推荐 保持更新的LAMP一键安装脚本

[复制链接]

218

主题

21

好友

663

积分

管理员

Rank: 9Rank: 9Rank: 9

admin 发表于 2015-3-17 12:51:34 |显示全部楼层
LAMP一键安装包大家应该不陌生, 即Linux + Apache + MySQL + PHP 运行环境。目前,主流的WEB运行环境有LNMP及LAMP等,闲吧一直在用LNMP一键包,用起也比较顺手。不过,LNMP对有些程序的支持不是非常好,特别是伪静态方面,故偶尔还是需要使用LAMP这个非常常用的WEB环境一键搭建包。这里闲吧将自己觉得还不错的LAMP一键安装包推荐给大家,当然也是为自己留个记号,以备用,呵呵~
LAMP一键安装包介绍
    1. LAMP 指的是 Linux + Apache + MySQL + PHP 运行环境
    2. LAMP 一键安装包是用 Linux Shell 语言编写的,用于在 Linux 系统(Redhat/CentOS/Fedora)上一键安装 LAMP 环境的工具脚本。


LAMP一键安装包功能
    支持 PHP 自带所有组件;
    支持 MySQL ,MariaDB, SQLite 数据库;
    支持 OCI8 (可选安装);
    支持 pure-ftpd (可选安装);
    支持 memcached (可选安装);
    支持 ImageMagick (可选安装);
    支持 GraphicsMagick (可选安装);
    支持 Zend Guard Loader (可选安装);
    支持 ionCube PHP Loader (可选安装);
    支持 XCache ,Zend OPcache (可选安装);
    命令行新增虚拟主机,操作简便;
    自助升级 PHP,phpMyAdmin,MySQL 或 MariaDB 至最新版本;
    支持创建 FTP 用户;
    一键卸载。


LAMP一键安装包安装要求
    需要 2GB 及以上磁盘剩余空间
    需要 256M 及以上内存空间
    服务器必须配置好软件源和可连接外网
    必须具有系统 Root 权限
    建议使用干净系统全新安装


LAMP一键安装包安装软件
    1、Apache 2.4.10
    2、MySQL 5.6.22, MySQL 5.5.41, MariaDB 5.5.41, MariaDB 10.0.15 (四选一安装)
    3、PHP 5.4.37, PHP 5.3.29, PHP 5.5.21 (三选一安装)
    4、phpMyAdmin 4.3.8
    5、OCI8 2.0.8 (可选安装)
    6、xcache 3.2.0 (可选安装)
    7、pure-ftpd-1.0.36 (可选安装)
    8、memcached-1.4.22 (可选安装)
    9、Zend OPcache 7.0.4 (可选安装)
    10、ImageMagick-6.9.0-3 (可选安装)
    11、GraphicsMagick-1.3.20 (可选安装)
    12、Zend Guard Loader 3.3 (可选安装)
    13、ionCube PHP Loader 4.7.3 (可选安装)


LAMP一键安装包安装步骤安装 wget、screen、unzip,创建 screen 会话
  1. yum -y install wget screen unzip
  2. screen -S lamp
复制代码


下载、解压、赋予执行权限
  1. wget --no-check-certificate -O lamp.zip https://github.com/teddysun/lamp/archive/master.zip
  2. unzip lamp.zip
  3. cd lamp-master/
  4. chmod +x *.sh
复制代码


或者下载包含所有安装包的源码(210.2M)来安装
  1. wget http://lamp.teddysun.com/lamp.tar.gz
  2. tar -zxf lamp.tar.gz
  3. cd lamp/
  4. chmod +x *.sh
复制代码


安装 LAMP 一键安装包
  1. ./lamp.sh 2>&1 | tee lamp.log
复制代码


安装其它模块
  1.     1、(可选安装)执行脚本 xcache.sh 安装 xcache 。(命令:./xcache.sh)
  2.     2、(可选安装)执行脚本 oci8_oracle11g.sh 安装 OCI8 扩展以及 oracle-instantclient11.2。(命令:./oci8_oracle11g.sh)
  3.     3、(可选安装)执行脚本 pureftpd.sh 安装 pure-ftpd-1.0.36。(命令:./pureftpd.sh)
  4.     4、(可选安装)执行脚本 ZendGuardLoader.sh 安装 Zend Guard Loader。(命令:./ZendGuardLoader.sh)
  5.     5、(可选安装)执行脚本 ioncube.sh 安装 ionCube PHP Loader。(命令:./ioncube.sh)
  6.     6、(可选安装)执行脚本 ImageMagick.sh 安装 imagick 的 PHP 扩展。(命令:./ImageMagick.sh)
  7.     7、(可选安装)执行脚本 GraphicsMagick.sh 安装 gmagick 的 PHP 扩展。(命令:./GraphicsMagick.sh)
  8.     8、(可选安装)执行脚本 opcache.sh 安装 Zend OPcache 的 PHP 扩展。(命令:./opcache.sh)
  9.     9、(可选安装)执行脚本 memcached.sh 安装 memcached 及 memcached 的 PHP 扩展。(命令:./memcached.sh)
  10.     10、(升级脚本)执行脚本 upgrade_php.sh 将会升级 PHP 和 phpMyAdmin 至最新版本。(命令:./upgrade_php.sh | tee upgrade_php.log)
  11.     11、(升级脚本)执行脚本 upgrade_mysql.sh 将会升级 MySQL 至已安装版本的最新版本。(命令:./upgrade_mysql.sh | tee upgrade_mysql.log)
  12.     12、(升级脚本)执行脚本 upgrade_mariadb.sh 将会升级 MariaDB 至已安装版本的最新版本。(命令:./upgrade_mariadb.sh | tee upgrade_mariadb.log)
复制代码


PHP升级脚本upgrade_php.sh说明新增 upgrade_php.sh 脚本,目的是为了自动检测和升级 PHP 和 phpMyAdmin。这两种软件版本更新比较频繁,因此才会有此脚本,方便升级。
使用方法:
./upgrade_php.sh | tee upgrade_php.log
MYSQL升级脚本upgrade_mysql.sh说明新增 upgrade_mysql.sh 脚本,目的是为了自动检测和升级 MySQL。升级之前自动备份全部数据库,在升级完成之后再将备份恢复。
使用方法:
./upgrade_mysql.sh | tee upgrade_mysql.log
MARIADB升级脚本upgrade_mariadb.sh说明新增 upgrade_mariadb.sh 脚本,目的是为了自动检测和升级 MariaDB。升级之前自动备份全部数据库,在升级完成之后再将备份恢复。
使用方法:
./upgrade_mariadb.sh | tee upgrade_mariadb.log
LAMP一键安装包使用方法
  • lamp (add,del,list):创建(删除,列出)虚拟主机。
  • lamp ftp(add|del|list):创建(删除,列出)ftp用户。
  • lamp uninstall:一键卸载lamp(卸载之前注意备份好数据!)。

LAMP一键安装包程序目录
  • mysql目录: /usr/local/mysql
  • mysql data目录:/usr/local/mysql/data(默认,安装时可更改路径)
  • php目录: /usr/local/php
  • apache目录: /usr/local/apache

LAMP一键安装包命令一览
  • mysql命令: /etc/init.d/mysqld(start|stop|restart|reload|status)
  • apache命令: /etc/init.d/httpd(start|stop|restart|reload|status)

LAMP网站根目录
  • 默认web根目录: /data/www/default

闲吧个人用此LAMP一键安装包非常顺利,也非常好用,所以推荐给广大的站长朋友使用,最后感谢脚本作者秋水逸冰



您需要登录后才可以回帖 登录 | 注册

Archiver|手机版|八零后时代 ( 苏ICP备07509334号 )

GMT+8, 2020-8-7 08:06

Powered by Discuz! X2.5

© 2001-2012 Comsenz Inc.

回顶部